Back
Downtime

Bets are not being accepted

Started 23 Sep at 06:01pm UTC, resolved 23 Sep at 07:00pm UTC.

Sports & Cybersports betting
Resolved

The issue has been fixed on the SportRadar side. Tests appear to show that no issues are present at the time

Posted 23 Sep at 07:00pm UTC.
Created

Both Live Odds system and MTS are not available on the BetRadar side, further details are being investigated by on their side.

Posted 23 Sep at 06:01pm UTC.