Back
Resolved

Marketing offers cannot be reached

Started 13 Oct at 03:50pm UTC.

Other incidents
Created

Due to the bug in the production environment Marketing offers cannot be reached with a 404 error. This is currently being looked

Posted 13 Oct at 03:50pm UTC.