Back
Maintenance

Scheduled maintenance of BI services

Completed 2 Mar at 08:00pm UTC.

BI dashboard
Completed

Maintenance completed

Posted 2 Mar at 08:00pm UTC.
Started

Migration of DC2 and BI2 to the new server.

Posted 2 Mar at 03:00am UTC.